Installieren Sie .NET Framework 3.5, 3.0, 2.0 unter Windows 8/10.

BEI Windows 8/10.NET Framework 4.5 ist standardmäßig eingestellt. Da .NET 4.5 ein direktes Update auf 4.0 ist, können Sie automatisch alle Anwendungen starten, die darauf abzielen .NET Framework 4.5 oder 4.0. Das ist gut, aber was ist, wenn Sie Programme ausführen müssen, die ältere Versionen erfordern? .NET-Framework ? Was ist die niedrigste Version, die Sie ausführen können?

BEI Windows 8/10 .NET 3.5, 3.0 und 2.5 werden mit dem Betriebssystem geliefert, Sie müssen sie nur aktivieren. Dies ist sehr praktisch, da Sie .NET 3.5 nicht von der Website herunterladen müssen Microsoft . In diesem Beitrag zeige ich Ihnen, wie Sie alte Versionen aktivieren .NET-Framework in Windows 8/10 .

BEI Windows 8 gehen Sie zuerst zu starten Bildschirm(Startbildschirm) und beginnen Sie mit der Eingabe von „Windows einschalten…“ und klicken Sie auf „ Einstellungen(Einstellungen) » auf dem Bedienfeld Wunderknöpfe. (Charms) Sie sollten die Option ” Schalte Windows Funktionen ein oder aus(Schalte Windows Funktionen ein oder aus) ” .

BEI Windows 10 Klick einfach “Anfang(Start)”, eingeben “Windows-Funktionen(Windows-Funktionen drehen)” und drücken Sie “Enter”.

Auf dem Desktop erscheint ein Dialogfeld und die erste Option ist .NET Framework 3.5 (enthält .NET 2.0 und 3.0)(.NET Framework 3.5 (enthält .NET 2.0 und 3.0)) . GeradeAktivieren Sie (einfach) dieses Kontrollkästchen und diese Funktionen werden installiert, ohne dass Sie etwas von herunterladen müssen Internet(Internet).

Punktraster

Einzelversion .NET-Framework die nicht enthalten ist Windows 8/10 – Das .NET-Framework 1.1. Wenn Sie es installieren möchten, müssen Sie es von hier herunterladen:

https://www.microsoft.com/en-us/download/details.aspx?id=26

.NETZ Rahmen 1.1 eingebaut Windows 8/10 , sodass Sie Anwendungen ausführen können, die für diese Version der Plattform geschrieben wurden. Möglicherweise erhalten Sie während der Installation eine Kompatibilitätswarnung, aber das war es auch schon. Andernfalls sollte es installiert werden und gut funktionieren.

Beachten Sie auch, dass Windows 8/10 intelligent ist und wenn Sie eine App installieren möchten, die dies erfordert .NET Framework 3.5 , wird ein Popup-Fenster angezeigt, in dem Sie gefragt werden, ob Sie diese Funktion installieren möchten, was das gleiche ist, wie wir es oben manuell getan haben. .

Netzwerkinstallation des Frameworks

Für IT-Experten, die installieren möchten .NET-Framework auf der Windows-Server 2012 hier ist, wie es geht.

1. Gehen Sie zum Server-Manager, klicken Sie auf ” Kontrolle(Verwalten)” und klicken Sie dann auf ” Rollen und Funktionen hinzufügen(Rollen und Funktionen hinzufügen) » . Klicken Sie dann auf Weiter.

2. Sie sehen den Bildschirm ” Installationsart auswählen”(Installationsart auswählen) und die Sie auswählen möchten rollen- oder funktionsbasierte Installation(rollenbasierte oder funktionsbasierte Installation) und klicken Sie auf Weiter.

3. Jetzt auf dem Bildschirm ” Auswahl des Zielservers(Zielserver auswählen)” Wählen Sie den Zielserver aus und klicken Sie auf ” Des Weiteren(Nächste) ” .

4. Sie sehen den Bildschirm ” Auswählen von Serverrollen(Serverrollen auswählen)” und Sie müssen erneut klicken ” Des Weiteren(Nächste) ” .

5. Schließlich auf dem Bildschirm ” Wählen(Select) Komponenten “Sie können das Kästchen ankreuzen” .NET Framework 3.5-Funktionen(.NET Framework 3.5-Funktionen) » .

Windows-Server 2012

Wow! Es ist ein langer Prozess, aber so macht man es Windows-Server 2012 . Zu beachten ist auch, dass beim Update von Windows 7 bzw Windows-Server 2008 R2 auf Windows 8/10 oder Windows Server 2012 (Windows-Server 2012).NET Framework 3.5 schaltet sich automatisch ein. Das ist alles. Genießen!

Bei Windows 8/10 wird .NET Framework 4.5 standardmäßig installiert. Da .NET 4.5 ein direktes Upgrade von 4.0 ist, können Sie automatisch alle Anwendungen ausführen, die auf .NET Framework 4.5 oder 4.0 ausgerichtet sind. Das ist in Ordnung, aber was ist, wenn Sie Programme ausführen müssen, die ältere Versionen von .NET Framework erfordern? Was ist die niedrigste Version, die Sie ausführen können?

In Windows 8/10 werden .NET 3.5, 3.0 und 2.5 mit dem Betriebssystem geliefert, Sie müssen es nur aktivieren. Das ist wirklich nett, weil Sie .NET 3.5 nicht von der Microsoft-Website herunterladen müssen. In diesem Beitrag zeige ich Ihnen, wie Sie die älteren Versionen von .NET Framework in Windows 8/10 aktivieren.

Gehen Sie in Windows 8 zuerst zum Startbildschirm und beginnen Sie mit der Eingabe von „Turn Windows…“ und klicken Sie auf Einstellungen in der Charms-Bar. Sie sollten eine aufgerufene Option sehen Schalte Windows Funktionen ein oder aus.

Windows-Funktionen

Klicken Sie unter Windows 10 einfach auf Start und geben Sie ein Windows-Funktionen drehen und drücken Sie die Eingabetaste.

Ein Dialogfeld wird auf dem Desktop angezeigt und die erste Option lautet .NET Framework 3.5 (enthält .NET 2.0 und 3.0). Aktivieren Sie einfach dieses Kontrollkästchen, und die Funktionen werden installiert, ohne dass Sie etwas aus dem Internet herunterladen müssen.

Dot-Net-Framework

Die einzige Version von .NET Framework, die nicht mit Windows 8/10 geliefert wird, ist .NET Framework 1.1. Wenn Sie das installieren möchten, müssen Sie es von hier herunterladen:

https://www.microsoft.com/en-us/download/details.aspx?id=26

.NET Framework 1.1 wird unter Windows 8/10 installiert, sodass Sie Anwendungen ausführen können, die für diese Version des Frameworks geschrieben wurden. Möglicherweise erhalten Sie bei der Installation eine Kompatibilitätswarnung, aber das war es auch schon. Andernfalls sollte es installiert werden und gut funktionieren.

Beachten Sie auch, dass Windows 8/10 intelligent ist und wenn Sie eine Anwendung installieren, die .NET Framework 3.5 benötigt, wird ein Meldungsfeld angezeigt, in dem Sie gefragt werden, ob Sie diese Funktion installieren möchten, was dasselbe ist, was wir oben manuell getan haben .

Net-Framework installieren

Für diejenigen IT-Leute, die .NET Framework auf Windows Server 2012 installieren möchten, gehen Sie wie folgt vor.

1. Gehen Sie zu Server Manager, klicken Sie auf Verwalten und dann auf klicken Rollen und Funktionen hinzufügen. Klicken Sie dann auf Weiter.

2. Sie sehen die Installationstyp auswählen Bildschirm und Sie auswählen möchten Rollenbasierte oder funktionsbasierte Installation und klicken Sie auf Weiter.

3. Jetzt auf der Zielserver auswählen Bildschirm, wählen Sie Ihren Zielserver und klicken Sie auf Weiter.

4. Sie sehen die Serverrollen auswählen Bildschirm und Sie müssen erneut auf Weiter klicken.

5. Schließlich können Sie auf dem Bildschirm Features auswählen das Kontrollkästchen für aktivieren .NET Framework 3.5-Funktionen.

Windows-Server 2012

Wütend! Das ist ein langer Prozess, aber so machen Sie es auf Windows Server 2012. Beachten Sie außerdem, dass .NET Framework 3.5 automatisch aktiviert wird, wenn Sie Windows 7 oder Windows Server 2008 R2 auf Windows 8/10 oder Windows Server 2012 aktualisieren. Das ist alles. Genießen!